ICON

FIND ANSWERS QUICKLY!

ICON
Reply
Jawbone Member
dmx_bojong
Posts: 3
Registered: ‎10-24-2011
0 Kudos

Flashing Red Light when charging

Hi, can anyone help me here ?

I got Jawbone icon for sometime, almost 1 year and it worked flawlessly until today

 

I try to plug the Icon for charging and it only display flashing red light.

Turning on the Icon give no response. I've tried to do a reset as recommended by some post in the forum but still to no avail

It keep displaying flashing red light. Have tried the reset several times :smileysad:

 

Can anyone suggest anything ?

Jawbone Apprentice
JawboneEmma
Posts: 779
Registered: ‎01-27-2010
0 Kudos

Re: Flashing Red Light when charging

Hello dmx_bojong

 

Thank you for taking the time to post in the Jawbone User Forum. I'm sorry to hear that you are having trouble with you ICON. If you have already performed a soft reset with out improvement you may want to try to perform a MyTALK update on your ICON to reinstall the firmware.

 

You can do this at the MyTALK website http://mytalk.jawbone.com by signing up for an account, downloading and installing the Jawbone Updater and then plugging your ICON into your computer using the Micro USB Charging cable directly into a USB port. Once the MyTALK site recognizes your ICON you should be able to click on the bright green "Sync" button near the top left of the page.

 

This should resolve the problem. If you have any questions or if you get stuck anywhere in the directions let us know so that we can further assist you.

 

Your Friend in Bluetooth,
JawboneEmma

Jawbone Member
dmx_bojong
Posts: 3
Registered: ‎10-24-2011
0 Kudos

Re: Flashing Red Light when charging

Hi Emma,

Thanks for replying. I've tried to follow yoyur suggestion however it still give no result

 

I've succesfully login to MyTalk and update to the latest client (v1.6.3 for Mac)

Afterwards, I plugged the icon into one of the USB. MyTalk still displaying the same message "No Device Connected"

My Icon on/off position is on Off when I plugged it into USB

 

Do you have any other suggestion ?

 

Jawbone Apprentice
JawboneEmma
Posts: 779
Registered: ‎01-27-2010
0 Kudos

Re: Flashing Red Light when charging

Hello again dmx_bojong,

 

I'm sorry to hear that those steps didn't get your ICON back into shape. There are a few things that could keep MyTALK from connecting to your device. The most common of these is the use of a USB hub rather than a USB port directly attached to your computer. A faulty USB cable could also cause this to happen as could a problem with the actual headset.

 

If you are using USB port that is part of your computer, or if you switch to one and still are unable to get your headset recognized by the MyTALK site it may be that your ICON is not in working order. Because you are outside of the US in order to receive warranty support you would need to contact your original seller as specified by the international warranty information which can be found at  http://aliph.custhelp.com/app/answers/detail/a_id/17.

 

Your Friend in Bluetooth,
JawboneEmma

Jawbone Member
dmx_bojong
Posts: 3
Registered: ‎10-24-2011
0 Kudos

Re: Flashing Red Light when charging

hi Emma,

I read in the forum that there's a hard reset method which might be able to help, however with slight chance that it might brick the device

 

Since I got nothing to lose by trying, can you suggest how to do this ? 

Jawbone Apprentice
JawboneEmma
Posts: 779
Registered: ‎01-27-2010
0 Kudos

Re: Flashing Red Light when charging

[ Edited ]

Hi dmx_bojong,

 

Because of the small chance that a hard reset could render a headset unusable, company policy does not allow me to post these directions in the Jawbone User Forum.

 

Please accept my apologies for any inconvenience this may have caused you.

 

Your Friend in Bluetooth,
JawboneEmma

Jawbone Member
CatAnne
Posts: 3
Registered: ‎06-08-2012
0 Kudos

Re: Flashing Red Light when charging

I've been having this same problem (flashing/pulsating red light, never turns white, no ability to connect with phone). Support walked me through the resets. Did not work. Since I purchased through Costco (authorized seller) the rep said he could send me a replacement. 

 

I turned down the replacement. I will return to Costco for a refund. According to posts on this site, many others are having this problem, and because they used an unauthorized reseller they can't get a replacement. This problem seems to be widespread.

 

I will not support a company that does not replace a malfunctioning product (due to a product flaw) just because the consumer didn't get it in the right store. I don't like it when companies use loopholes in the warranty as an excuse not to deal with faulty product design. I plan to post my thoughts online wherever I see this product being sold.